Lancer Nation

Honesty Always Welcomed!
 
Lancer NationLancer Nation  HomeHome  FAQFAQ  RegisterRegister  Log inLog in  

Share | 
 

 Lancer Jerky at High speed

View previous topic View next topic Go down 
AuthorMessage
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Lancer Jerky at High speed   Fri Mar 05, 2010 10:25 am

Hi everyone!!

Would like to highlight my problem here hopefully it would help myself and others who may face the same problem as mine.

Mods done:
1. Autofoam - KL Auto
2. Alternator booster - KL Auto
3. Electrical grounding - KL Auto
4. Pivot Mega Raizin purple VS

Other than that, everything is stock. Even resisted the urge to put in HID lights.

My problem is, whenever I on my lights, my car constantly pull back when I try to accelerate above 120 km/h. It is more obvious during highway drive when I try to maintain certain high speed. Ordinary city drive, (80km/h - 100km/h) it is not obvious at all.

I've tried switching off the air-cond - it's still the same. Then I tried manual mode - it's still the same. The car jerks when at high speed. If I switch off the lights, the car is normal and responsive.

I've checked my alternator & battery. They're OK. My car is currently at AP Puchong SC for the past 5 days. They too are at wits end coz they've checked the air flow sensor, ECU and all.

A good samaritan PM-ed me to try to get MMM to send technician to have a look at the wiring. My question is does MMM have a service centre? How to get hold of their technicians?



This footage was taken some months ago when the car go crazy.
Back to top Go down
Reverend
Admin
avatar

Number of posts : 355
Vehicle Type : Lansi
Registration date : 2009-09-08

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 12:30 pm

Sounds like CVT is changing gear ratio when you turn on the lights.

If this is the case, I have absolutely no idea what is the connection between the CVT and the headlights.

Ignoring the jerk when you turn on the headlights, can the car still accelerate like normal after the jerk (i.e. after you turn on the lights)?
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 12:42 pm

If you can, avoid driving the car when you need to use your headlamps.

SC is looking at the wrong places since there is nothing wrong with the ECU/TCU/other CU's or the wireharness.

Check the relays visually and switch them around and go for a test drive. Best if there is a donor relay that you can use and test. When one relay pops, it usually affect other relays as well. Resetting them may not work. IIRC, there is a relay for headlamps.

This looks like a relay problem. Do not let this prolong because over long term, this will overload the capacitors (hence leak and destroy the IC) in your ECU/TCU/Other CU's. (Basically I have had this problem before and spent countless $$ solving it. But by the time I replaced the relays, my ECU was already being eaten by capacitor fluid).
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 3:01 pm

Rev - No, I can't accelerate even if I ignore the jerk. Whenever I step on the accelerator, the car pulled back. I cannot maintain constant speed 100 km/h.

Donyong - I suspect it's electrical related just as much. I'll call SC to look into relay switches... thanks. Out of curiosity, which SC finally solved your car relay problem?
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 3:05 pm

No SC solved it for me. I did it myself after going thru all the sensors, wire harness, volt readings and ohms myself on my old car. By that time, it was already too late, I had to get a new ECU. (that too I told the mechanic to do it after he tried all other means).

If SC cannot provide you the relays, you could by them off somewhere, its shoud be quite cheap, usually around RM30 per piece.
Back to top Go down
gelygeleman
Member
avatar

Number of posts : 900
Vehicle Type : Mitsubishi Lancer GT
Registration date : 2010-03-03

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 9:28 pm

beagle, dun gv up searching the prob cause..
Back to top Go down
Elan
Member
avatar

Number of posts : 534
Vehicle Type : Lancer GT
Registration date : 2010-03-02

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 05, 2010 11:16 pm

bro did u try to maintain rpm at 2-3k with lights on at "N" or "P" mode, does the rpm fluctuate or normal.
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Sat Mar 06, 2010 1:37 am

gelygeleman - I won't. Now my mileage is 35k... I'm hoping I can get this solved before the warranty runs out. (Just in case if it's gearbox problem at least I won't go bankrupt...)

Elan - how to maintain RPM at 2-3k on 'N' or 'P' mode? I don't know how but I have to assume RPM won't fluctuate. Reason - If I keep my speed at 80km/h or below, it's very normal (with lights on). It's only when I try to go above 100km/h then the jerk becomes very evident. Off hand I can say this jerking only happens at 6th gear.
Back to top Go down
strike961
Member


Number of posts : 139
Vehicle Type : Lancer GT
Registration date : 2009-11-10

PostSubject: Re: Lancer Jerky at High speed   Sat Mar 06, 2010 5:43 pm

i went to Auto Pacifica to sort out my damaged bearing.

I saw beagle's car waiting there very kesian...

Hope - speedy recovery!!!!
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Sat Mar 06, 2010 9:27 pm

strike961 wrote:
i went to Auto Pacifica to sort out my damaged bearing.

I saw beagle's car waiting there very kesian...

Hope - speedy recovery!!!!

Ouch... my poor baby.....
Back to top Go down
jan999
Member
avatar

Number of posts : 164
Vehicle Type : Lancer GT
Registration date : 2009-10-30

PostSubject: Re: Lancer Jerky at High speed   Sun Mar 07, 2010 12:24 pm

beagle do give them a chase on it. they probably sit on it.

this definitely something very wrong. so must resolve it as soon.

good luck bro
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Sun Mar 07, 2010 9:41 pm

Jan999 - Ipoh SC don't want to get involve, I'm worried after Puchong SC also don't want to get their hands dirty if I push too hard. Really susah.... I spent this weekend using public transport to get around and it just dawned on me how difficult life can be without a car!!
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Tue Mar 09, 2010 8:58 am

A little update on my car. It is still at the SC, but they called to inform me it's now in the hands on Mitsubishi technicians. MMM tech people came to check my car (dun know should feel honor or not... ) and you know what? They've no closer to finding out the cause than Puchong SC. It seems they tried everything and today, as a last straw, MMM will be supplying a new ECU to test on my car. Hopefully things can be resolved ASAP.

I felt 'handicapped' without a car in the city. BUt then I am relieved Puchong SC and MMM is helpful. Will continue to update when I got news.
Back to top Go down
Reverend
Admin
avatar

Number of posts : 355
Vehicle Type : Lansi
Registration date : 2009-09-08

PostSubject: Re: Lancer Jerky at High speed   Tue Mar 09, 2010 10:49 am

Best of luck to you, beagle!
Back to top Go down
strike961
Member


Number of posts : 139
Vehicle Type : Lancer GT
Registration date : 2009-11-10

PostSubject: Re: Lancer Jerky at High speed   Tue Mar 09, 2010 7:26 pm

keep us posted Beagle...
Back to top Go down
Scissorshand
Member
avatar

Number of posts : 255
Vehicle Type : Lancer GT
Registration date : 2009-11-03

PostSubject: Re: Lancer Jerky at High speed   Thu Mar 11, 2010 8:45 pm

Bro Beagle,

Its been 2 days ady, any update???? Any conclusion?

Hope it turns out well with the new ECU
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Thu Mar 11, 2010 11:41 pm

Hey peeps,

Scissorshand - Thanks for asking!!

A little update: I just got my car back this evening. MMM has replaced my car with a new engine ECU. They've tested my car after installing the new ECU for 2 days and so far so good wor. All my add ons... Pivot VS, alternator booster & grounding are removed. (Lucky autofoam cannot be taken out. If not....)

I'm not exactly out of the woods yet. They've asked me to test the car for another 2 weeks. If everything is OK, then I'll install back all the add ons.

Am keeping my fingers crossed and will continue to update.
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 12, 2010 9:08 am

Very good of MMM to give you a new ECU to test. ECU's are vehicle specific and cannot be transferred to another car.

Better put back the add on and test now to see whether the add-ons cause the problem.

My guess is your ex-ECU has a leak from the installation of add-ons eg. electrical shock, etc.
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 12, 2010 9:22 am

Don - I'll wait 2 weeks before putting back the add ons. Just to be sure the problem is solved with the replacement of an ecu.

I very doubt the cause is those add ons. I had this problem way before my add ons and the very reason I did all those grounding etc and Pivot is because I initially thought my jerking problem is due to unstable electricity flow...

Yeah, grateful to MMM for living up to their side of the bargain.
Back to top Go down
Scissorshand
Member
avatar

Number of posts : 255
Vehicle Type : Lancer GT
Registration date : 2009-11-03

PostSubject: Re: Lancer Jerky at High speed   Fri Mar 12, 2010 9:45 am

I'm happy for you Beagle!!!!!!!!!!!!!!!!! As i said, hoped this is resolved permanently. Cheers and enjoy yr ride again!
Back to top Go down
beagle
Member
avatar

Number of posts : 14
Vehicle Type : 9th Gen black Lancer GT
Registration date : 2009-11-26

PostSubject: Re: Lancer Jerky at High speed   Mon Mar 15, 2010 9:26 am

A little update after testing my car on the highway. Conclusion? It seems it has nothing to do with the engine ECU at all. Here I am compensated with a brand new ECU and yet, the problem is still the same.

I am now more inclined than ever to go with Donyong's initial assessment it is a wiring/relay problem.

The dilemma I'm facing now is.....

1. After confirming it is a wiring problem, should I now go to a wiring expert specializing in wirings as opposed to going back to SC?

Don, you mentioned you tested and solved your wiring problem by yourself... you did not go to any workshop at all for the tools etc? I'm not as tech savvy as you, I'll definitely need outside help. Any tips?
Back to top Go down
Scissorshand
Member
avatar

Number of posts : 255
Vehicle Type : Lancer GT
Registration date : 2009-11-03

PostSubject: Re: Lancer Jerky at High speed   Mon Mar 15, 2010 9:11 pm

TIEW!!!!!!!!!!!!!!!!!!!! WTF!!!!!!!!!! Still da same shit???!!!!! Man, looks like SC is still yr best solution to resolve lor.....
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Tue Mar 16, 2010 10:29 am

Sorry for the late reply.

How I guessed its a relay problem? Simple, On/Off situation (i.e. pointing to relay and maybe wiring).

*** Make sure your ignition key is at OFF.

Open up your fuse box in the engine bay. Look at the underside of the fuse cover for the relay locations. Find the relay (rectangular box) that has the headlamps icon. IIRC, the relay is brown in colour and is situated next to the injector relay. IIRC, both headlamps relay and injector relays are the same.

Remove that headlamp relay (by wriggling it left right up down) until it pops.

Now put the ignition into ACC and turn on the headlamps. You notice that the dashboard lights should be on but there is no headlamps. Switch it off.

Now, start the car and go for a drive till you reach the critical speed that you have the jerking problem. Turn on the headlamps. (It should be off since you took off the relay).

Anything happens? If no, then it should be the relay. If there continues to be jerkyness, then it could be a wiring issue then. (maybe the wiring is not grounded properly or exposed).

There is another fuse box near the aircond box, but IIRC, that has nothing to do with the headlamps.

Try this for now.

Let me know....

ps. when you put back the relay you removed earlier, make sure your engine is off. When putting it back, you may hear a click, that is normal.
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Wed Mar 17, 2010 9:08 am

Sorry, just checked, its the relay is black in colour and is labelled as G on the fuse map at the underside of the fuse cover.
Back to top Go down
Scissorshand
Member
avatar

Number of posts : 255
Vehicle Type : Lancer GT
Registration date : 2009-11-03

PostSubject: Re: Lancer Jerky at High speed   Mon Apr 05, 2010 8:40 pm

Hi Beagle,

Any update??? Its been another 2 weeks ady since u last posted???

Cheers!
Back to top Go down
strike961
Member


Number of posts : 139
Vehicle Type : Lancer GT
Registration date : 2009-11-10

PostSubject: Re: Lancer Jerky at High speed   Mon Apr 05, 2010 9:03 pm

i went to fix my front wheel ABS sensor last Fri. Beagle's car still waiting there sadly with the mech clueless on what's going on..
Back to top Go down
donyong
Member


Number of posts : 308
Vehicle Type : Lancer GT 2.0
Registration date : 2008-07-18

PostSubject: Re: Lancer Jerky at High speed   Fri May 07, 2010 5:11 pm

Despite all that has been changed, the problem still persist. No matter whether you change the gearbox, ecu, etc, it will still persists.

Sometimes, a small/simple problem give big symptoms.

Listen lah, change the who wire harness. If still not ok, change the whole relay box.
Back to top Go down
Scissorshand
Member
avatar

Number of posts : 255
Vehicle Type : Lancer GT
Registration date : 2009-11-03

PostSubject: Re: Lancer Jerky at High speed   Fri May 07, 2010 10:51 pm

i think Beagle might as well sue them and get replacement unit lor
Back to top Go down
Sponsored content




PostSubject: Re: Lancer Jerky at High speed   

Back to top Go down
 
Lancer Jerky at High speed
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» High speed wobble (another explanation)
» FOUND THE HIGH SPEED WOBBLE PROBLEM
» Short Type - High Speed Motor
» high speed wobble
» Craftsman Off Road/ High Speed Tractor Build

Permissions in this forum:You cannot reply to topics in this forum
Lancer Nation :: Feedback & Complaints :: Lancer Car Issues :: 9th Generation Lancer Issues-
Jump to: